PHP 5.4

A PHP 5.4 esete a Radius hitelesítéssel

  • Beküldve: 2013. március 28, 10:19
  • Szerző: Bolemányi Attila

Adott egy Debian Linux (Squeeze) szerver, amelyen az 5.3-as PHP-t frissíteni kellett az 5.4-es változatra. A PHP csomagok a Dotdeb tárolóiból származnak. A szerveren egy Moodle e-learning keretrendszer fut, amely a felhasználókat egy Radius szerver segítségével hitelesíti, így természetesen szükség van a PHP Radius támogatására is. A PHP frissítése közben azonban a php5-radius csomag eltávolításra került, mivel a függőségekből hiányzott a phpapi-20090626+lfs nevű virtuális csomag.

Nem probléma, hiszen a pecl install radius parancs segítségével a szükséges Radius támogatás könnyedén telepíthető. Azonban a csomag fordításakor a következő hibaüzenettel leállt a telepítés: